WordPressでリンクが貼れない/貼っても切れてしまうときの応急処置

この記事は約6分で読めます。

lgf01a201411022100

 

いつものようにWordPressで記事を書き、リンクを貼ろうと思ったそのとき!!

 

急に変な表示が。

スクリーンショット 2016-04-20 11.32.39  

 

こんなの今まで見たことなかったので、「???」とは思いましたが、試しにこの白い部分にURLを入れてクリックしてみました。

 

すると、見た目上は「リンクが貼れたかな?」と思うのですが、実際にプレビューや公開後に見るとリンクが切れてしまう事態に( ;´Д`)  

 

「では」と次の手段へ。

 

歯車をクリックしてみました。

 

すると・・・

 

このような画面になり、今まで表示されていた「既存のコンテンツ」が表示されず、ブログカードを作成することが出来なくなってしまいました( ; _ ; )

スクリーンショット 2016-04-20 11.48.24  

 

*ブログカードについてはこちら。

Simplicityで初心者でも簡単に記事中にブログカードを設置する方法
わたしは、わいひら様の開発したテーマ、「Simplicity」を使用してこのブログを書いています。初心者にも簡単なカスタマイズ方法が盛り沢山で、本当に感謝・感激のテーマです!!その中で、わたしが感動した機能のひとつがコレ♫記事中に他の記事を...

 

さて、これは困りました・・・( ;´Д`)

 

とりあえず、解決策を探ってみることに。

 

注意:

 

ここでは、なぜリンクが貼れなくなってしまったかの原因究明までは至っていないため、書いておりません。

 

ただ、以下の3つは修正することが出来ました。

 

  • またリンクが貼れるようになった。

 

  • 「既存のコンテンツ」が表示されるようになった。

 

  • 「ブログカード」が表示されるようになった。

 

ここでは、それまでにわたしが行った手順を説明しています。

 

正確な原因が不明なため、この手順で行っても解決出来るかどうかはわかりません。

 

ただ、この方法を試してみるのはアリかと思います。

 

無事解決出来ることを祈ります!!!

スポンサーリンク

リンクを貼れるようにするまでの手順

原因を探る

 

まず、どうしてリンクが貼れなくなってしまったのかを思い返してみました。

 

わたしの場合、プラグイン「WP Multibyte Patchのアップデートの後くらいからでした。

 

それをするまでは通常通りだったので、なんとな〜くコレが怪しいような感じがしました。

(まず、おかしくなる直近にアップデートしたプラグインを疑ってみましょう!!!)

 

原因だと考えられるプラグインを停止する

 

一旦、WP Multibyte Patchを停止してリンクが貼れるか確認してみました。

 

やはりリンクは貼れませんでした。

 

プラグインの本家で確認する

 

「ダッシュボード」→「プラグイン」→「インストール済みプラグイン」から、各プラグインの詳細情報が見られたり、こういったトラブルに対する作者からの解決方法が書かれているページに行けたりします。

 

WP Multibyte Patchの場合はこちらから。

WP Multibyte Patch
本家版、日本語版 WordPress のマルチバイト文字の取り扱いに関する不具合の累積的修正と強化を行うプラグ…

 

すると、このような記述を発見。

「投稿画面でリンクの挿入ができない」 → 古いバージョンの WP Multibyte Patch を使用している場合、互換性の問題が起こることがあります。お使いの WordPress で利用可能な最新版に更新してください。また、同時に使用しているプラグインやテーマの JavaScript コードにバグがあり、そのエラーが WP Multibyte Patch の wplink.js の実行をブロックしてしまっているケースも報告されています。例: AddQuicktag の JavaScript バグ。JavaScript のコンソールにエラーが出ていないか確認してください。

 

WordPress自体は最新バージョンにアップデートしたばかりだったので、考えられるとしたら他のプラグインやテーマのJavaScriptコードにバグがある可能性・・・

 

また、プラグインAddQuicktagとWP Multibyte Patchを同時に使用すると不具合が起こりやすいらしいですが、わたしはAddQuicktagは使用していないのでこれは無視して考えます。 

 

とりあえず、ここはきちんとひとつひとつ確認してみる必要があるようです。

(大変ですが、頑張りましょう!!!)

 

すべてのプラグインを全停止・原因だと思われるプラグインだけ有効にしてみる

 

すると!!!  

 

リンク挿入のボタンをクリックしたときの表示が、このように変化。

(さっきより白い部分が長くなりました)

スクリーンショット 2016-04-20 21.03.12

 

この状態で、白い部分にURLを入力し、青い部分の「適用」をクリックしてプレビューで表示してみると・・・

 

なんと、きちんとブログカードが表示されました(°O°)

 

しかも、リンクは切れていません。

 

少しホッ♪( ´▽`)

 

でも、まだ安心は出来ません。

 

次に、歯車をクリックしてみると・・・

 

先ほどまで表示されなかった「既存のコンテンツ」が表示されるようになりました!!!

スクリーンショット 2016-04-20 14.22.25  

 

試しに項目を選択し、「リンク追加」をクリックすると・・・

 

きちんとリンクが貼れました♪( ´▽`)

 

下書き保存をし、プレビューで表示してみると・・・

 

きちんとブログカードが表示されています!!!

 

ここまで来ると、「バグ修正か?!」と思いましたが、また新たな疑問が( ;´Д`)

 

なんと、歯車から設定した場合、編集画面に戻るとリンクが切れてしまうことが判明しました・・・

 

白い部分に直接URLを入力して適用させたリンクは切れないのに、歯車から設定したリンクは切れてしまうというなんとも気持ちの悪い現象に・・・

 

プレビューでは、きちんと表示されていたのになぜ?!?!?!

 

本当に謎です。

 

プラグインをひとつずつ有効化しながら様子を探る

 

先ほど停止したプラグインを、ひとつひとつ有効化すると同時に、投稿画面にてリンク挿入を試しながら様子を見てみました。

 

すると、目立った異変はなく・・・

 

結局、最後までプラグインを有効化出来ました。

 

また、リンクも先ほどと同様、直接入力ならきちんと貼れて、編集画面に戻ってもリンクは切れず、歯車を使用して挿入すると、表示は問題なくされますが、投稿編集の画面に戻ると切れてしまうという事態のままとなりました。

 

追記:リンクが切れなくなりました。

 

次の日、試しにリンクを貼った記事の編集をしてみたところ、白い部分から設定したリンクも、歯車から設定したリンクも切れていませんでした。

 

んー・・・

 

一時的な不具合だったのでしょうか・・・

 

とりあえず、プラグインを全停止する方法は効果的でした!!

 

まとめ

 

いくら調べてみても原因がわからず、非常に気持ち悪いのですが、とりあえずいまのところは「応急処置」とさせていただきます。

 

きちんとした原因がわかり次第、ここに追記したいと思います。

 

または、原因が分かる方、教えていただけたら幸いです。

 

中途半端で申し訳ありません。

 

この記事を読んでいただき、どうもありがとうございました!!

 

またお会いしましょう。

コメント

タイトルとURLをコピーしました